Clutch finger ticking noise - Kawasaki Teryx Forum
Engine and Drivetrain For discussion of drive train and engine performance and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 06-08-2011, 08:11 PM Thread Starter
 
divepdic's Avatar
 
Join Date: Nov 2010
Location: So. Illinois
Posts: 152
Clutch finger ticking noise

Was wondering if anyone has this issue, the noise I'm having is only at idle and is definately coming from the clutch, I can tell because when I cover the vent opening I can barely hear it. My first thought is the clutch is dragging the case but I know I torqued to 69 lbs, anyway I pulled the cover yesterday and I had plenty of clearance between clutch and case, so I got to pushing, pulling, and noticed that there was no tension on the fingers they had some slop, and while moving the fingers back and forth I was able to replicate the clicking noise. Now this noise is only present at idle if I so much as raise rpms by about 10 it stops, and I guess my question is would different springs help this noise? I am currently running a dasa OD plate with stock springs and fingers. Thanks
divepdic is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-09-2011, 04:11 AM
Teryx coming soon
 
Join Date: May 2011
Location: Nova Scotia, Canada
Posts: 13
There are things called "buttons" that the clutch spider slides on. They wear out.

Mine wore in my Brute Force and I had the dealer replace them.. About $60 for parts and labour when I brought the clutch to them.

Its the part between the 4 star shape thing with the roller and the 8 fingers. You cant see the buttons in the picture.
Madkawi750 is offline  
post #3 of 10 (permalink) Old 06-09-2011, 08:42 AM Thread Starter
 
divepdic's Avatar
 
Join Date: Nov 2010
Location: So. Illinois
Posts: 152
Quote:
Originally Posted by Madkawi750 View Post
There are things called "buttons" that the clutch spider slides on. They wear out.

Mine wore in my Brute Force and I had the dealer replace them.. About $60 for parts and labour when I brought the clutch to them.

Its the part between the 4 star shape thing with the roller and the 8 fingers. You cant see the buttons in the picture.
Wore out? I only have 200 mi. on this rex, I guess I should have disclosed that in my first post. I'm assuming the rollers should be resting on the fingers at all times, which in my case they are not
divepdic is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 06-09-2011, 09:51 AM
Teryx coming soon
 
Join Date: May 2011
Location: Nova Scotia, Canada
Posts: 13
Didnt realize your mileage was so low.. Shouldn't wore out yet.. Although my brute had 400 miles when mine were noisy.. I bought it used and the 1st owner rode a lot of dust roads. I was blown away because my other 2 brutes had over 2500 miles with no issues..
The noise was more of " clock clock clock" than a tick tick tick.
Madkawi750 is offline  
post #5 of 10 (permalink) Old 06-09-2011, 04:10 PM
 
Gantt425's Avatar
 
Join Date: Sep 2008
Location: New River AZ
Posts: 340
i put on a utv inc overdrive plate and replaced the belt and ended up with a similar noise. later i put in a clutch kit and like you couldnt find any issues. my noise is under part throttle cruising. at wot, it goes away. i would love for someone to point out whatever it is im missing aswell....
Gantt425 is offline  
post #6 of 10 (permalink) Old 06-09-2011, 04:26 PM
Teryx coming soon
 
Join Date: May 2011
Location: Nova Scotia, Canada
Posts: 13
Every Kawi I ever heard has that cluck cluck sound when under light throttle going slow in a trail.. I was told it was the fly weights and I would have to live with it.. It's a normal noise just like all yammy's sound like they're eating crank bearings.
Madkawi750 is offline  
post #7 of 10 (permalink) Old 06-09-2011, 06:19 PM Thread Starter
 
divepdic's Avatar
 
Join Date: Nov 2010
Location: So. Illinois
Posts: 152
Quote:
Originally Posted by Madkawi750 View Post
Every Kawi I ever heard has that cluck cluck sound when under light throttle going slow in a trail.. I was told it was the fly weights and I would have to live with it.. It's a normal noise just like all yammy's sound like they're eating crank bearings.
I would say this is more of a tink tink sound more than a cluck, cluck, if you have your clutch off and you flip your clutch fingers back and forth its a metal to metal noise, while we're making all these sounds can I get a moo moo!!!!!LOL
divepdic is offline  
post #8 of 10 (permalink) Old 06-09-2011, 07:58 PM
Premium Member
 
bigdaddy3's Avatar
 
Join Date: Oct 2009
Location: Farmerville Louisiana
Posts: 877
When I got my first side x side I like to drove my self crazy with all of the noises I heard, finally realized that in the cabs you hear alot more noises than on a quad especially if you have any type of windshield and you are just idleing around, the cvt systems will drive you crazy so now when I hear one of those little sounds I just nail the throttle and the muzzys just sound so good. LOL

Big Daddy
bigdaddy3 is offline  
post #9 of 10 (permalink) Old 06-09-2011, 08:08 PM Thread Starter
 
divepdic's Avatar
 
Join Date: Nov 2010
Location: So. Illinois
Posts: 152
Quote:
Originally Posted by bigdaddy3 View Post
When I got my first side x side I like to drove my self crazy with all of the noises I heard, finally realized that in the cabs you hear alot more noises than on a quad especially if you have any type of windshield and you are just idleing around, the cvt systems will drive you crazy so now when I hear one of those little sounds I just nail the throttle and the muzzys just sound so good. LOL
Sounds like a good resolution to the problem to me!!!
divepdic is offline  
post #10 of 10 (permalink) Old 06-09-2011, 08:30 PM
POOR KID RACING
 
moto4life9099's Avatar
 
Join Date: Feb 2010
Location: corona,ca
Posts: 239
If you at any point overtightend the bolt for the front drive pully it could be the cooling fins on the back side of the pully hitting the back plate. I did this and it def made a tic tic tic noise that your talking about and off idle you do not hear it. You will be able to see it on the back plate if you look at it. I'm almost positive that's possibly your problem

08 BLACK AND BLUE TERYX, DEVIANT ILLUSION LT, FST 840, FCR 39S, VFJ STAGE III, XMF CAGE, TWISTED STITCH SEATS, RUGGED RADIO, LOWRANCE GPS, SAFEGLOW WHIP
moto4life9099 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome