Kawasaki Teryx Forum Header Left   Kawasaki Teryx Forum Header Right

Losing Coolant

This is a discussion on Losing Coolant within the Engine and Drivetrain forums, part of the Kawsaki Teryx Forum Technical category; Every 30 minute ride I lose about 1/4 of the coolant in the reserve tank. Can't find where it is leaking or going. There is ...


Go Back   Kawasaki Teryx Forum > Technical > Engine and Drivetrain

Engine and Drivetrain For discussion of drive train and engine performance and maintenance

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-03-2012, 08:19 PM
workn911calls's Avatar  
Join Date: Nov 2011
Location: Riverside
Posts: 37
Losing Coolant

Every 30 minute ride I lose about 1/4 of the coolant in the reserve tank. Can't find where it is leaking or going. There is a slite coolant burning smell after I stop. I checked all the hose seem fine. Any suggestions?
Reply With Quote
Sponsored Links
TeryxForums.net is the premier Kawasaki Teryx Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
   
  #2 (permalink)  
Old 01-03-2012, 08:29 PM
waytay's Avatar
Premium Member
 
Join Date: Sep 2008
Location: Ramona, ca
Posts: 1,622
stock or built?
__________________
I support BENCHMARK PERFORMANCE, HRT Motorsports, K-2 concepts, multiple forums, CBR Radiators, FOX shocks, COGNITO , Golden West Drain Service, RIGID Lighting, LUCAS RACING, WORCS racing series, FIBERSKINS, RUGGED radios, more to come. TOO broke to buy a new car every year*********** !! COME ON KAWASAKI bring us something to be proud of !!***************
Reply With Quote
  #3 (permalink)  
Old 01-03-2012, 08:44 PM
workn911calls's Avatar  
Join Date: Nov 2011
Location: Riverside
Posts: 37
Stock
Reply With Quote
  #4 (permalink)  
Old 01-03-2012, 09:06 PM
Freeezen's Avatar
Premium Member
 
Join Date: Apr 2009
Location: Anaheim, CA
Posts: 3,485
I know you said you checked the hoses, but did you take off the skids and check the hoses below the motor and also under the tunnel? Some have had head problems that led to losing coolant and overheating problems. Just some ideas.
__________________
2009 Kawasaki Teryx Sport Benchmark SBK, CNC ported heads, +1mm valves, stock clutch lightened to 73 grams, LTI +5" suspension, FU2Chassis cage, Induced Fab doors, 27x9 Mongrels, DASA exhaust w/quiet cores, DASA impeller, DASA OD clutch plate, DASA KEBC plate, MSD, bored throttle bodies, FuelUTV Siphon break, UNI air filter, lime green secondary spring, Agressor seats, TripleX bench, oem replacement HIDs, 6.5" LEDs on the A pillar, Fiber Skinz diff skids, UTV Inc. Temp gauge, UTV Inc. fan bypass, SSV stereo.
Safety is no accident
Reply With Quote
  #5 (permalink)  
Old 01-03-2012, 09:14 PM
workn911calls's Avatar  
Join Date: Nov 2011
Location: Riverside
Posts: 37
No i didn't check the hoses under the skids. I will check it once i get home thursday morning. Thanks for the idea Freeezen
Reply With Quote
Reply

Lower Navigation
Go Back   Kawasaki Teryx Forum > Technical > Engine and Drivetrain


Search tags for this page
09 zx6r losing water
,
250 john deere losing water
,
450 kawasaki buring antifreeze
,

change radiator fluid on teryx

,
john deere kawasaki losing coolant
,

kawasaki , loseing water

,

loosing coolant within minutes

,
ninjagpz600coolant
,

teryx4 antifreeze smell

,
yamaha ninja radiator leak
,
yamaha rhino losing coolant
,
zx 600 ninja water leak problems
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:05 AM.