Kawasaki Teryx Forum Header Left   Kawasaki Teryx Forum Header Right

2008 teryx problem

This is a discussion on 2008 teryx problem within the Forum Help, Questions, and Info forums, part of the Kawsaki Teryx Forum Members category; hello, I just purchase a 2008 teryx. I power washed under the drive seat which I know now was a big no no. but since ...


Go Back   Kawasaki Teryx Forum > Members > Forum Help, Questions, and Info

Forum Help, Questions, and Info Read Here First!

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-27-2010, 03:37 PM
 
Join Date: Jun 2010
Location: Lancaster Ohio
Posts: 4
Unhappy 2008 teryx problem

hello,

I just purchase a 2008 teryx. I power washed under the drive seat which I know now was a big no no. but since I did this I get a buzz when I turn off the engine its appears to be coming from the engine area. and my engine brake is no longer working. if I am driving it's fine but when I take my foot off the gas it sounds like a rattling noise from the transmission area. I checked the 4 fuses in th fuse box and they are good. thanks in advance!!!!
Reply With Quote
Sponsored Links
TeryxForums.net is the premier Kawasaki Teryx Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
   
  #2 (permalink)  
Old 06-27-2010, 10:58 PM
klx450r's Avatar
Premium Member
 
Join Date: Dec 2008
Location: escondido
Posts: 2,577
if it goes away after a few seconds it is the engine brake its normal they all do it.
__________________
www.fuelutv.com
Reply With Quote
  #3 (permalink)  
Old 06-28-2010, 05:54 AM
 
Join Date: Jun 2010
Location: Lancaster Ohio
Posts: 4
it appears it the belt actuator.

also the engine noise only appears to be in LO. i'm not sure if this could be the belt actuator?

thanks

Last edited by buckmaster; 06-28-2010 at 06:08 AM. Reason: Automerged Doublepost
Reply With Quote
  #4 (permalink)  
Old 06-28-2010, 08:58 PM
 
Join Date: May 2010
Location: illinois
Posts: 8
hey guy, i just got a new 08 teryx and it does the same thing. i think u r hearing the fuel pump .i also get a low speed noise when it is in low. sounds like belt flopping could possibly be the engine brake thing. i own a atv shop but i havent had time to investigate but it is also still under warrenty so im not messing with it although they gave me permission to do as i please with it.does urs run extra warm when in the cab?
Reply With Quote
  #5 (permalink)  
Old 06-28-2010, 10:02 PM
klx450r's Avatar
Premium Member
 
Join Date: Dec 2008
Location: escondido
Posts: 2,577
its not the fuel pump, the brake on top of the clutch housing resets when u turn off the key that is the noise you hear when you turn the key off its a buzzing noise that last for a few seconds. just removed mine when i installed the over drive cover no more noise.
__________________
www.fuelutv.com
Reply With Quote
  #6 (permalink)  
Old 08-02-2010, 03:20 AM
 
Join Date: Aug 2010
Location: wuhan
Posts: 1
Thank you, I will meet you share this question, I have been searching for answers
Reply With Quote
  #7 (permalink)  
Old 08-12-2010, 05:35 PM
FIFDTRUE's Avatar  
Join Date: Sep 2008
Location: Wyoming
Posts: 31
Unhappy HELPP with noise!!

I believe I am having the same issue. It is a very loud chatterish sound. I changed my belt a few weeks ago and ever since I have had this Hellacaious noise. In neutral the noise is non existant. Soon as I put it in gear low or high I get a noise that is very loud. Sounds like a U joint is out like the drive line is slapping, but I have checked all joints. Then I thought it might be the belt slapping the housing, but the belt is fine (right deflection set) and I have ran it without the cover and its not that. Then I thought maybe its coming from the rear end but it is extremly hard to tell. Anyone else having these problems? HELP would extremely be appreciated!!!!!
__________________
!!!52-Welsh Racing-52!!!
Reply With Quote
  #8 (permalink)  
Old 08-13-2010, 04:29 PM
dave_dj1's Avatar  
Join Date: Sep 2008
Posts: 172
I'm not sure on all the details but if you unplugged the clutch brake fork and ran the machine it has to be reset. I don't recall the procedure but search and you should find it.
Reply With Quote
  #9 (permalink)  
Old 08-13-2010, 04:56 PM
crow's Avatar  
Join Date: Apr 2009
Location: East Central Alberta
Posts: 183
Quote:
Originally Posted by dave_dj1 View Post
I'm not sure on all the details but if you unplugged the clutch brake fork and ran the machine it has to be reset. I don't recall the procedure but search and you should find it.
I believe that if the belt plug is off & you turn the key on, it will need to be reset. So unhook you battery or remove key when working on the belt.
Reply With Quote
  #10 (permalink)  
Old 08-15-2010, 04:47 PM
FIFDTRUE's Avatar  
Join Date: Sep 2008
Location: Wyoming
Posts: 31
Quote:
Originally Posted by crow View Post
I believe that if the belt plug is off & you turn the key on, it will need to be reset. So unhook you battery or remove key when working on the belt.
Ok I will definently unhook the battery. Thanks for your guys help I will give it a shot and see if that helps!

Quote:
Originally Posted by dave_dj1 View Post
I'm not sure on all the details but if you unplugged the clutch brake fork and ran the machine it has to be reset. I don't recall the procedure but search and you should find it.
I appreciate the input. Any clues to where I can find this though? I have searched on here and other sites and can't seem to come up with anything. Any help would be greatly appreciated!!
__________________
!!!52-Welsh Racing-52!!!

Last edited by FIFDTRUE; 08-15-2010 at 05:09 PM. Reason: Automerged Doublepost
Reply With Quote
  #11 (permalink)  
Old 08-16-2010, 06:26 AM
dave_dj1's Avatar  
Join Date: Sep 2008
Posts: 172
search under KBEC, I think.
I searched here and found not much info, kbec or engine break, maybe call the dealer and ask for specs on resetting the kbec?

Last edited by dave_dj1; 08-16-2010 at 06:32 AM.
Reply With Quote
  #12 (permalink)  
Old 08-16-2010, 09:32 AM
FIFDTRUE's Avatar  
Join Date: Sep 2008
Location: Wyoming
Posts: 31
Quote:
Originally Posted by dave_dj1 View Post
search under KBEC, I think.
I searched here and found not much info, kbec or engine break, maybe call the dealer and ask for specs on resetting the kbec?
Alright sounds good, thanks for the information!
__________________
!!!52-Welsh Racing-52!!!
Reply With Quote
  #13 (permalink)  
Old 08-16-2010, 09:51 AM
sdave420's Avatar
race it or wast it???
 
Join Date: Oct 2009
Location: 951. MENIFEE
Posts: 249
Quote:
Originally Posted by FIFDTRUE View Post
I appreciate the input. Any clues to where I can find this though? I have searched on here and other sites and can't seem to come up with anything. Any help would be greatly appreciated!!
go to Hunterworks pull up teryx accessories and go to dalton clutch kit. there is like 4 videos that will show you everything or just call him he will help for sure.
__________________
08 POKE-A-SORIS-REX , burkmotopros hids, uni with adapter, E bay fog/dust lamps, Gearone rack, XMF LT, safe glo whip, sdr cage, prp bench and harnesses, muzzy pro,hw carb kit, dalton clutch, cdi, hw od cap.
Reply With Quote
Reply

Lower Navigation
Go Back   Kawasaki Teryx Forum > Members > Forum Help, Questions, and Info


Search tags for this page
08 teryx cdi problems?
,
08 teryx problems
,
08 teryx rear seat
,
08 teryx what is the sound when you turn the key on
,
2008 kawasaki teryx forum
,
2008 kawasaki teryx forums
,

2008 kawasaki teryx problems

,

2008 teryx problems

,
kawasaki tyrex 2008 problems
,
problem with kawasaki 2008 terx
,
problems with 2008 kawasaki teryx
,
problems with the 2008 kawasaki teryx
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.teryxforums.net/forum-help-questions-info/9694-2008-teryx-problem.html
Posted By For Type Date
2008 teryx problem - Kawasaki Teryx Forum This thread Refback 06-27-2010 04:22 PM


All times are GMT -7. The time now is 08:52 AM.