WANING!!!! check the clamps on the boots that go to the intake under the center conso - Kawasaki Teryx Forum
General Teryx Discussion For General Teryx talk. If it's about Teryx's and does not fall into another category, it belongs here!

 1Likes
  • 1 Post By Gearhead
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-09-2019, 06:59 PM Thread Starter
 
Gearhead's Avatar
 
Join Date: Nov 2018
Posts: 192
WANING!!!! check the clamps on the boots that go to the intake under the center conso

So yesterday i took off the center console to have a look because the last run out i could smell a rubber burning smell. Im pretty sure it was the belt i smelt but maybe it was something else getting hot. Well everything looked good so now i know it was the belt getting alittle to hot. Anyway as i was looking around under the console for some reason i remembered a post i read about someone had to do a top end job on a 2014 teryex because after a few years of riding the motor ingested dust because the clamp on the intake was never tightened down from the factory. So i decided to check the clamps that hold the intake duck work to the top of motor and sure enough mine weren't tight at all . On both clamps i got about 6 to 7 more turns. Maybe its just mine and maybe they were tight enough but i know if i was to pull up on that intake tube it would've pulled right off. The pressure from the center console resting on top of the tube will probably hold it in place from vibrating out but i would think these v-twins have a lot of suction and the clamps being that loose would allow fine dust to still be ingested in . I just wanted to let you guys know about what i found on my 2018 teryex hopefully it is just mine but i would check yours just to be safe .
Johnbob likes this.
Gearhead is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-10-2019, 01:14 PM
dlb
Administrator
 
dlb's Avatar
 
Join Date: May 2011
Location: USA
Posts: 3,726
That's a good reminder for everyone to check their connections. I think I mentioned this quite some time ago that the intake plenum was a little loose on mine as well. I don't think any dirt got in, but over time those clamps may have loosened and caused major issues. It's also a good idea to check the clamps on the air box tube as well.

TERYX FORUMS TEAM
CHECK OUT MY YOUTUBE CHANNEL:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
dlb is offline  
post #3 of 4 (permalink) Old 06-10-2019, 05:30 PM Thread Starter
 
Gearhead's Avatar
 
Join Date: Nov 2018
Posts: 192
A little bit of dust can do major damage to the top end . Im glad it came to my mind when i had the console off.
Gearhead is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-11-2019, 05:23 AM
 
Join Date: Mar 2012
Location: Oak Ridge TN
Posts: 72
I have found this issue in my machine recently. I put in a clean air filter after each ride and noticed it was not as dirty as it should be. it has slipped off the airbox. Pain in the butt to get back on and tight.
Danno is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome