Loss of power. - Kawasaki Teryx Forum
Intake and Fuel Anything Air/Fuel related.

 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 08-14-2018, 08:09 AM Thread Starter
 
Join Date: Aug 2018
Posts: 4
Garage
Loss of power.

2013 Teryx Loss of power after it gets warm.
This is the second time I have had this problem. Replaced the fuel pump and that fixed it the first time.
Just replaced fuel pump again, but still loses power after about 10 minutes. While it is cold it runs fine. Anyone else have this problem?
lwjdnme is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 08-14-2018, 02:56 PM
 
Baddazzbigblue's Avatar
 
Join Date: Jun 2018
Location: Podunk Utah
Posts: 365
Garage
change plugs & dump a can of Seafoam in full tank
Baddazzbigblue is offline  
post #3 of 12 (permalink) Old 09-27-2018, 03:46 PM
 
Join Date: Sep 2018
Location: Carson City, Nevada
Posts: 6
Garage
maybe check you fuel tank vent to make sure it isn't plugged. I've relocated mine and added a filter.
Desert_ryder is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 12-19-2018, 07:14 PM
 
Join Date: Feb 2018
Location: Omak, Washington
Posts: 12
Garage
Had same issue with my 17' T2 the fuel pump filter was plugged from the poor tank vent design pulled it apart had a spare pump filter for my Kingquad in my garage cured the problem. INSTALL REMOTE FUEL TANK VENT WITH FILTER ran it up under center console
Rcdriver_50 is offline  
post #5 of 12 (permalink) Old 12-20-2018, 08:39 AM
dlb
Administrator
 
dlb's Avatar
 
Join Date: May 2011
Location: USA
Posts: 3,812
Thread moved from recall section to more appropriate sub-forum.

TERYX FORUMS TEAM
CHECK OUT MY YOUTUBE CHANNEL:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
dlb is offline  
post #6 of 12 (permalink) Old 05-15-2019, 05:23 PM Thread Starter
 
Join Date: Aug 2018
Posts: 4
Garage
Where is your tank vented to? Mine has a vent tube into the roll cage. Changed spark plugs, had valves adjusted. same problem. If something doesn't help soon, I will find it a new owner. Beginning to think the 2013 was a bad purchase.
lwjdnme is offline  
post #7 of 12 (permalink) Old 05-15-2019, 05:34 PM
DILLIGAF
 
Berserker's Avatar
 
Join Date: Apr 2012
Location: UP/WI
Posts: 634
Garage
If you ask people here, there are no bad teryxes. My service manual doesn't live with me.

Do they have fuel pressure regulator? Put a fuel pressure gauge on there may the thing to do. Need to find out if a fuel problem or spark. Do you think both cylinders are firing when it bogs down?

I realize what I said is extemely vague.
Berserker is offline  
post #8 of 12 (permalink) Old 05-15-2019, 07:39 PM Thread Starter
 
Join Date: Aug 2018
Posts: 4
Garage
It acts like someone shut the fuel off, Spitting, coughing, jumping. Spark plugs and fuel pump changed with new fuel filter. Valves adjusted, still no help. Planning to check fuel vent. No pressure regulator. Stands to reason if you can't get the tank vented, fuel won't pump out. Even the fuel tank needs to breath.
lwjdnme is offline  
post #9 of 12 (permalink) Old 05-15-2019, 07:42 PM Thread Starter
 
Join Date: Aug 2018
Posts: 4
Garage
Thanks for the suggestion. I never thought of that, but even the fuel tank must breath.
lwjdnme is offline  
post #10 of 12 (permalink) Old 05-15-2019, 10:11 PM
DILLIGAF
 
Berserker's Avatar
 
Join Date: Apr 2012
Location: UP/WI
Posts: 634
Garage
full tank may need to breath more

I have read lots of discussions on fuel vent lines on lots of various types of machine. Worth looking in to, but I suspect something else.

But it does get brought up a lot on all over, so never know.
Berserker is offline  
post #11 of 12 (permalink) Old 05-16-2019, 07:18 AM
 
Join Date: Sep 2018
Location: Carson City, Nevada
Posts: 6
Garage
The pressure regulator is inside the fuel pump, it is a check valve type. You did change out the entire fuel pump assembly or just the pump inside?
Desert_ryder is offline  
post #12 of 12 (permalink) Old 05-16-2019, 07:53 PM
 
Join Date: Feb 2018
Location: Omak, Washington
Posts: 12
Garage
HFP-A490 Fuel Pump Assembly Replacement for Kawasaki Teryx KRF750 KRF800/Teryx4 KRT800/KRT750/PRO-FXT/FX EFI (2009-2018) Replaces 49040-0716, 49040-0733
This is the pump I put in my 2017 after confirming that the pressure was dropping out after about 17-19 miles when it got warm this pump carries a lifetime warranty and it runs perfectly.
I put a remote K&N breather filter up under the center console the one that goes into the frame was allowing dirt to get in and plugging up the pump suction filter found very fine dirt inside the tank removed it and flushed completely
Rcdriver_50 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome