Kawasaki Teryx Forum - Reply to Topic
Engine and Drivetrain For discussion of drive train and engine performance and maintenance

Thread: Check engine light when in 4x4 Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
 
 
   

Register Now



In order to be able to post messages on the Kawasaki Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-18-2019 07:06 PM
Haulinyall Well fellow trailblazers! I have spent the weekend reading and troubleshooting. The manual says if the 4x4 does not work, it is either the EPS, Actuator or battery not connected. It was the actuator.
I took the actuator off and it has a black connector with three wires that does not disconnect. Right next to the wires is a little white button. A breaker maybe? An internal fuse or something?
Anyways, I pushed it in with a screwdriver. Before I bolted the actuator back on, I cranked the Teryx and moved the selector to 4x4 and the actuator worked!! I turned the selector back to 4x2, shut down and bolted the actuator back in place.
There was some dry mud and debris in-between the actuator housing, maybe this tripped the “breaker”.

I wonder how much the dealership would have charged me for such a simple fix?

Thanks guys for your help. I hope I saved another Teryx owner from an unnecessary expense......
08-14-2019 04:13 PM
JstWantoRide It could have nothing to do with the spacers and the actuator is just on its way. Actuators dying is very common. Check out the Knight manual 4wd kit, it will fix all of your problems! Www.knightatv.com


Sent from my iPhone using Tapatalk
08-13-2019 09:21 AM
6.2Blazer Also don't sit there and switch the dial back and forth repeatedly. If the engine light comes on turn off the key, turn the 4wd dial back to the position it showed it was in (indicator says 2wd then switch dial back to 4wd), then turn the key back on and try again. Mine will regularly freak out if you turn the dial back and forth quickly. For example I was in 2wd and meant to switch it to 4wd but turned it into diff lock on accident....immediately rotated the dial back from diff lock to 4wd and it will freak out 75% of the time. Obviously avoid that situation and only move the dial one position at a time now.
08-13-2019 09:17 AM
6.2Blazer I would check the connectors and wires at the front diff. Again, the wheel spacers should have zero effect to the system but maybe some of the wiring got bumped somehow when you were doing the work. Go in on the drivers side and look at the rear of the front diff. There are several wires that connect to the diff. Check to make sure the connectors are not loose or have fallen off, or if any of the wires are broken.

Also may not hurt to make sure the battery is fully charged....never heard of it causing this type of issue especially if it starts okay, but never hurts to make sure the voltage is correct.
08-12-2019 12:19 PM
Haulinyall 6.2~~
I tried switching standing still then moving, the CE light came on right away, 4x4 indicator stayed on 4x2.
Moving between 5-10 mph, CE light came on right away, 4x4 indicator stayed on 4x2.
Moving 5-10 mph, moving the steering wheel left and right, CE light came on right away, 4x4 indicator stayed on 4x2.

Thanks for helping with this everyone!
08-12-2019 10:22 AM
6.2Blazer The wheel spacers should have absolutely nothing to do with an issue switching to 4wd or the check engine light. The check engine light can come on if you try to switch between 2wd, 4wd, and diff lock but it doesn't actually change modes. What are the details around trying to put it in 4wd but it not engaging? Were you just sitting still the entire time? Were you driving/moving after switching to 4wd? How long was it between switching to 4wd and the engine light coming on?
08-11-2019 07:37 PM
Stormking No, not any more than normal. SOmetimes its a PIA and have to play with it to diff lock unlock. I am bad about stopping first to engage. Key off rarely to reset it to work. I have had eps light stuff on old trex and it turned out to be weak battery. Spacers do slow up the EPS but never been a problem in any way running spacers except more mud flying. Being 65 wide helps on sidehills and corners and wheeling rough big stuff.
08-11-2019 05:12 PM
Haulinyall Stormking... after you put on your 2 inch spacers, did you have any issues with your 4x4 or 4x4 lock?

I will try charging the battery and taking off the spacers on the front wheels to see if that makes a diffference.
08-11-2019 10:09 AM
Stormking Is it eps. Low voltage? full charge batt and try?
08-11-2019 06:12 AM
Baddazzbigblue have dealer check it out maybe ?
08-10-2019 12:38 PM
Haulinyall
Check engine light when in 4x4

I recently put 2 inch wheel spacers on a 2018 Teryx 4. When switched to 4x4, the check engine light came on and the 4x4 indicator did not change.

I switched the knob back to 4x2 and the check engine light did not turn off. I shut the machine off, then back on and the check engine light stayed off.

Thoughts/Ideas?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome