2014 T4 Using Oil - Kawasaki Teryx Forum
Teryx4 Dedicated discussions for the Kawasaki Teryx4 (Teryx4 Forum)

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Today, 05:46 PM Thread Starter
 
Join Date: Sep 2019
Posts: 1
2014 T4 Using Oil

Hi Everyone,
New to the side by side world, and purchased a 2014 T4 with 4400kms on it. The family and I drive, a lot. We got it in June and it now has 6500kms on it. I purchased from a dealer, and thought it might be using some oil, burning it or otherwise. They put 100 kms on it in the dead of summer, super hot, and it didn't seem to use any. It doesn't smoke, but I was wondering, given the mileage on it, is it typical to have to add some oil here and there, every 100-150kms, not even half a liter? I may be making a bigger deal out of it then I should....
Scradam is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Teryx Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome