Kawasaki Teryx Forum banner

21 - 40 of 42 Posts

·
Registered
Joined
·
5 Posts
I have exact same issue. I've checked everything. fuel pump isn't going to make it do this, when mashing the throttle snaps it out of it and allows it to climb hills. Low PSI = worse running as engine load is increased.. it'd be worse under heavy load than just cruising.

I've checked TPS, throttle cables and spring.

I'm thinking now it's related to the Electronic Engine Brake.. any one else agree? Where would I unplug that brake to test drive it. Currently have all plastics removed.

2016 Teryx 4 800
 

·
Registered
Joined
·
25 Posts
Anybody solve this? 2014 Teryx 2xx hours. Just started this issue and bogs at constant low throttle. Runs fine till warms up and then bogs when holding constant throttle at about 10 mph. Will almost die and then will all of the sudden pick back up on its own for a minute or so and then bog again . I have changed fuel filter, checked tank inlet check valve, put in new plugs and still does it. I've tugged and wiggled the coil wires while it's doing it with no difference. I'm not buying that it's a bad fuel pump as it will run 50 mph no problem. I've seen many posts with this problem but no real solution? Surely it's a common problem as wide as the problem is.
 

·
Registered
Joined
·
25 Posts
Any info on this issue?

I have a 14 with the same described problem. I have done a lot of research but haven't seen anyone with the solution. My unit has 2000 miles and ran great until a couple weeks ago. I have checked the tank vent, replaced the tank filter, blew out the fuel pump, put in new plugs. Drained all the gas and wiped the tank clean which is didn't need.

Run along with constant throttle at say 10 mph or so and it will slowly start bogging down. It will get slower and slower but never die. Then, it will begin running normally leaping forward. When I feel it starting to bog, I can feather the throttle a little and it will take off. It does it in low and hi, 4wd and 2wd. I tried it in low thinking the engine would be running at a higher RPM for the same speed as hi and it still does it.

I don't think it's the fuel pump as it will idle perfect and will run 50 mph as well.

Please somebody...tell me what the solution was for you.
 

·
Registered
Joined
·
6 Posts
I’m with you 100%. Same issue I’ve been trying to figure out for almost a year. I’ve Done all the same things. Even checked fuel pressure while it happens and it doesn’t flinch. I was thinking it was a flat spot on the throttle position sensor but it’s $800 for the throttle body assembly. I was thinking of trying new coils as they are cheaper but I can never get it to do it in neutral even when warm. The engine braking idea is interesting. Andrew520 did you find out if it can be disconnected? I have a feeling it’s not possible due to the centrifugal clutch, but I’m not sure how it works. Anyone know if there is a sensor that could be causing it to engage under throttle? Or is engine braking even related to throttle input? I’m not getting any engine lights when it happens. Im not much help,but I’m also hoping someone smarter than me can figure this out! Very frustrating.
 

·
Registered
Joined
·
25 Posts
New Fuel Pump didn't help

Just as I suspected and new fuel pump didn't help. I am determined to figure this out and the engine covers are not going back on until I do!

It seems like it runs out of fuel and not some brake or something binding and bogging the engine.. It's got to be with whats controlling the injectors?? The ECU?
 

·
Registered
Joined
·
3 Posts
Having the same issues......replaced the fuel line, added tank vent mod, replaced sparkplugs, checked spark, checked air filter, checked the pump, replaced the fuel pump strainer, and now it won't even start. Just cranks with nothing. I actually got it to start right after I changed the plugs, but it was bogging when I applied pressure to the gas pedal. Also I checked pressure on the tank and made sure the fuel flow was good all the way to the throttle body. Still can't figure it out. Taking it to a shop tomorrow. It was running fine and then out of the blue it died on us out on the trail.....did the vent mod, new fuel line, and fuel tank pump strainer and right after the damn thing is dead in the water. 2012 Teryx 4 EPS model.
 

·
Registered
Joined
·
86 Posts
I have read and reread this post and this may sound crazy and stupid but has anyone tried a seat belt bypass?
 

·
Registered
Joined
·
3 Posts
I have read and reread this post and this may sound crazy and stupid but has anyone tried a seat belt bypass?
I have not tried that. I will try to plug my seats back in and give that a whirl. Also I checked voltage on my battery last night while it was at rest and it was 12.36v......I read that these only start with a well charged battery over 12.7v. I got it to turn over one time yesterday but it would not stay running without me holding down the gas pedal. If the motor starts, won’t the voltage go up to like 14v or something, so to me that means its probably something other than the battery right?
 

·
Registered
Joined
·
2 Posts
I have the same issue with the steady throttle. I've tried new fuel pump and fuel screen on the bottom of the pump. Hoping someone is able to figure this out. Been looking for a fix the last couple of years.
 

·
Registered
Joined
·
50 Posts
I would say this is some sort of common problem, and nobody wants to share the answer, when I do get mine running again, there will be a for sale sign on it. # side by sides each had their own set of problems. Oil ring stuck in RZR, 1200 mi., wheels fall off Artic cat, Teryx bogs down and will not run. time for a Jeep.
 

·
Registered
Joined
·
293 Posts
Has anyone seen the threads about the second filter in the fuel pump housing? I think there was also one or two threads about the valves being so far out of adjustment they had no compression.

For the seat belt harness, it's just two wires, you can cut the plug and twist the wires together on the machine side and that "should" bypass the seatbelt buckle limiters. It shouldn't be rocket appliances.
 
21 - 40 of 42 Posts
Top