Kawasaki Teryx Forum banner
1 - 14 of 14 Posts

·
TEXAS RANGER
Joined
·
61 Posts
Discussion Starter · #1 ·
I did two runs today on a highway close to my place, we are in the country so no problem, but after running 55 or so for about 1/3 mile it starts acting like it is running out of gas, and I am not at full throttle.. I let off a little and it seems to catch up and then it does it again. When I am running around the pasture no problems, just extended runs. I installed the up grade computer box last month no other engine mods. Any ideals?? Thanks Paul
 

·
Registered
Joined
·
138 Posts
Mine does the same thing. I have a Dynatek CDI and a machined clutch sheave. Ive had it to 61mph(so far) so I know it will do it but sometimes it will only go to 58. I think the CDI(and correct me if im wrong) is designed to take it there but not for extended times.
 

·
Registered
Joined
·
77 Posts
you are hitting the Rev limiter. the Rev limiter is built in to kill spark to the motor at a certian RPM, I think it is 5000 rpms for the Stock CDI, I am not sure what the Limiter is on the various upgrades I think I read 8g on the dynatek non programmable.
 

·
Registered
Joined
·
307 Posts
Yeah, probably the rev limiter which may kick in at different speeds giving the riding varibables, terrain, wind, temp, etc.

You may have to adjust the floats in the carb bowls too, it could be starving for fuel if the float heights are too low. It needs all the fuel it can get at WOT in the upper RPMs.

Out!
 

·
Registered
2020 teryx4 800 krt800
Joined
·
5 Posts
Hi teryx4 800 just started cutting out at 25 mph after about 30-40 mins of run time and went go over 25 mph not the seat belt not the air filter checked the fuel filter that's in the tank it was blotchy black don't know if that's normal or not but ordered a new one putting it on and then I'll take it and try it again, FYI I only have 580 miles on my unit just bought it from dealer 4 moths ago they won't help me want to charge me to figure it out that's why I'm on here for maybe a answer thank u
 

·
Sep 2020 TOTM Winner
Joined
·
545 Posts
Hi teryx4 800 just started cutting out at 25 mph after about 30-40 mins of run time and went go over 25 mph not the seat belt not the air filter checked the fuel filter that's in the tank it was blotchy black don't know if that's normal or not but ordered a new one putting it on and then I'll take it and try it again, FYI I only have 580 miles on my unit just bought it from dealer 4 moths ago they won't help me want to charge me to figure it out that's why I'm on here for maybe a answer thank u
I think you're on the right track with the fuel filter, let us know if the new one fixes the issue. The only other limiter that would cause it to cut out is the diff lock speed limiter, but that hits at less than 25 mph. Do you have the fuel vent mod done on your machine? If not, check out this kit at Brute Performance to get the vent up higher and keep it from sucking in debris and water.
 

·
Registered
2020 teryx4 800 krt800
Joined
·
5 Posts
I think you're on the right track with the fuel filter, let us know if the new one fixes the issue. The only other limiter that would cause it to cut out is the diff lock speed limiter, but that hits at less than 25 mph. Do you have the fuel vent mod done on your machine? If not, check out this kit at Brute Performance to get the vent up higher and keep it from sucking in debris and water.
I don't have the mod done yet but I will soon been looking into it thank u so much for responding I've been trying for to weeks i get a answer like this from dealer and u answered in less then 12 hrs I'll let u know what happens then u have a great day
 

·
Jan, Jun, Oct 2021, Feb 2022 TOTM Winner
Joined
·
798 Posts
Thank u so much I fixed it with the filter took it out today did great u have no idea how much I appreciate it
If you haven’t already, I highly suggest running your fuel tank vent line up higher and maybe throw a little filter on it. The factory vent line is relatively low and just pushes into the frame under the passenger seat.
I ran mine up the roll cage to the roof.
 

·
Jan, Jun, Oct 2021, Feb 2022 TOTM Winner
Joined
·
798 Posts
I guess I did. I just added a long piece of vacuum hose to the other end of it. I didn’t bother with a clamp. It’s tight.
Automotive tire Gas Wood Automotive wheel system Rim
 
1 - 14 of 14 Posts
Top