Kawasaki Teryx Forum banner

1 - 7 of 7 Posts

·
Cooterbob
Joined
·
210 Posts
Discussion Starter #1
After my daughter was riding my teryx around the yard I noticed the fan would not shut off. The bike was not hot and I let it sit for over an 1hr and it still did not shut off. I have checked the connections and it still has not shut off. I start vacation sun. and have a big ride planned. Do you guys think it is the thermostat? Any other ideas? I am not wanting to take it in to the dealer bec. I know it will not be done before Sun.
 

·
Registered
Joined
·
134 Posts
The fan is initiated by a temp sensor in the radiator. You can see it from the driver side under front tire. It is a wire and sensor going into the radiator. Chech the wires on the sensor, make sure the wires are on good. Also there is a radiator fan breaker (relay) under driver seat, It is a square switch with a light blue button on top which should be pushed in. If it trips it will pop out. Check those things and see if it fixes it.
 

·
Cooterbob
Joined
·
210 Posts
Discussion Starter #3 (Edited)
I disconnected and reconnected the breaker relay and the fan still comes on. The Bike has not been running for about 4 hours now. I played with the wires coming into the fan and they appear to be on tight. I just hope I can get this fixed by sun. I guess I can still ride it , but just unhook the breaker relay until I get it fixed.

Mudbug,
You da man! I went back out side and checked the sensor wires to the radiator and one must have been loose because when I pushed on it, the fan shut off right away. I let it idle for about 20 min. and the fan came on and off. Would it hurt to use some diaelectric grease there? What a great place for info on the teryx! Thanks again Mudbug!!
 

·
El Moderator
Joined
·
4,038 Posts
You can use dielectric grease in any electrical connection. I inhibits corrosion by reducing oxidation on the metal contact pins. A "dielectric" is a poor conductor of electricity so don't worry about using it in all your connections.
 

·
Registered
Joined
·
2 Posts
Over heating

New here. Just got my teryx 2 weeks ago. Driving this weekend the temp light came on and it seeems like fan is not working. Checked fluid and fan breaker and they are OK. anyone else have this problem?
 

·
Registered
Joined
·
40 Posts
Does the Teryx not start and the temp light flashes on?

That happened to us the first ride so my dad read half way through the manual, and than I reached over pressed my foot on the brake and turned the key. It started right up, we rode my Uncles Rzr the day before I remembered thats how you gotta start em.
 
1 - 7 of 7 Posts
Top