Kawasaki Teryx Forum banner
1 - 7 of 7 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
I have a 2016 Teryx 800 2 seater and I just changed my belt, the brand I installed was badass belt, I drive it about 4 miles in low range at about 26 mph, when I got up to 30 mph I had a clicking sound so I back off to 22 mph , I got it back up to 30 again I heard the clicking sound again it almost sounded like I left in bolt inside the housing . Please help
 

Registered
2017 Teryx4
Joined
377 Posts
it almost sounded like I left in bolt inside the housing
I'm far from an expert and I've only done one belt change. If you think there is something bouncing around inside the housing then I would start by opening it up again. Who knows what you might find in there. I just found a nice filter wrench under the hood of my F-150...

(Full disclosure, I get a $9.95 oil change on that truck at the dealership, as long as I own it. 260,000 miles and still purrs like a kitten. 馃樇 They REALLY want me to trade that truck off....)
 

Registered
Joined
8 Posts
I've never pushed mine that hard in low but that's an interesting tidbit.
Agree - most bikes LOW is limited to about 20 MPH. If you are sure you replaced all the bolts, and positioned the belt correctly, you're probably ok. If in doubt, pull it back off and check. Better to be safe and lose some time..
 

Registered
Joined
1,229 Posts
You should not be going 30 mph in Low. 15 max
I run over 15 mph in low range all the time. Granted, if I know that I will be cruising at 20-30 mph for extended periods of time I will shift into high but have no issues running up to 30 mph for short periods of time in between trails or if it just opens up for a little bit.
 
1 - 7 of 7 Posts
Top