Kawasaki Teryx Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I own a 2010 teryx, and have quite a problem with it using oil. It will burn 12 oz. of oil for every 35 miles of riding time. The motor has about 20 hours on it since the top end was rebuilt, thought the rebuild would fix my problem but it didn't seem to, I have also installed a different breather kit on it to get read of oil being pushed into the intake. It also doesn't seem to have any leaks any where, Im stumped where is my oil going?
 

·
Registered
Joined
·
181 Posts
my '09 sport has from almost day one consumed 300ml on almost every 60-80 mile run.

I am so used to its consumption that I can pretty much bet that I will be putting in 300ml when I check it before a ride...

The teryx has over 6200 miles on it now and it always has consumed that amount in that range of miles.
 

·
Registered
Joined
·
1,335 Posts
I have one but not installed yet, got mine from Hunterworks, goes back into the crankcase. I'm hoping this helps me, it should help the smoking I get once and a while when I over fill the oil and hit higher rpms....ooops.
 

·
Registered
Joined
·
810 Posts
Man, you guys got me knocking on wood. My 2010 uses/burns no oil. I check it regularly and have never had to add any. Let us know what you find to be your problem.
 

·
Registered
Joined
·
81 Posts
I am using synthetic now. I have my clutch sent off to vforce John right now and just adjusted the valves. As soon as I can get it all put back together I have already bought the oil to change back to conventional and see what happens.
 

·
Registered
Joined
·
358 Posts
You should talk to vforce John about oil.
 

·
Registered
Joined
·
810 Posts
SouthCo, I'm real envious of your bloody machine! Seems like you have had zero problems! Don't mean to jinx you, but I hope it continues!!!:icon_thumleft:
Thanks and all these post make me nervous for sure. My teryx has been good to me. I don't dune, mud or rock climb. Just trail rides but I gas it on a regular. If my girl starts acting up, she's gotta go but I love her so I hope she keeps treating me good.
 

·
Registered
Joined
·
69 Posts
I have a 2011 Sport with MSD and a HW siphon kit. I am at about 800 miles right now. It hasn't used a drop the whole time I have owned it. Switched over to Rotella synthetic with the first oil change.

I read about all the problems folks have and it makes me nervous, but count me as one of those that hasn't had a single problem of any kind yet. My sister-in-law has an 09, and she hasn't had any problems either. She doesn't drive it as hard as I do mine though.
 
1 - 20 of 28 Posts
Top