Kawasaki Teryx Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter · #1 ·
Hey fellow forum users,

I need some help. I have a new '14 LE and My radiator broke open after 30 miles of riding.

After the service garage removed it, you could clearly see a "cut" in the shape of the spinning fan. Not a quick dent or like something busted through, but more like a very light rubbing that continue to cut the radiator after so long.


After they replaced it and I asked all my questions and looked at the fan blades thinking they were hurt (if it did shove something through it), I noticed I have a metal clip on the fan.

The service guy simply said it's there for balance. But this clip kind of looks like it may have been the original issue? I then looked at a new '14 on the showroom floor and it DID NOT have a clip. I asked my buddy with a '14, and his DOES NOT have a clip.

Why do I have this clip - is the service guy causing me issues (note: he's had my unit before this visit too)?

Does anyone have this clip? Should I remove it?

 

·
Registered
Joined
·
92 Posts
Take it back for warranty. I imagine it would be covered. I would call the dealer to resolve if it dont then call Kawasaki direct.
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #3 ·
Warranty is covering it. BUT, they acted like they are only being generous since it was new and since I had the belt issue too... Vforcejohn says that clip is a balancing clip...so I guess it's okay, I'll have to keep an eye on it.

At least Kawasaki did cover it! Kudos to team green!
 
1 - 3 of 3 Posts
Top