Kawasaki Teryx Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
I went mudding y-day and had teryx in lots of mud and water prolly 3ft deep, it did great!! It went all day fine, I got home and washed all down including lightly under seat to get mud out. Today I took out just riding down road and water temp light came on. I noticed fan wasnt running. I got home and found fan breaker was tripped. I reset and it came on but it was acting flaky. I would wiggle connections and it would cut off and on. This never happened y-day when deep in water, did washing it do this? It was submerged y-day. Is this breaker waterproof? I will prolly order a new one. Anyone else have this problem?
 

·
I WANT ONE
Joined
·
202 Posts
I have heard of others having this problem. Seems to be the plug-in on the fan doen't fit all that tight and wiggles loose
 

·
Registered
Joined
·
186 Posts
mine did that the other day,tripped the breaker ran fine and then my coolant light went on. I turned the fan manually and a rock flew out it started right up.use a stick if you ever think you may have the same problem that fan goes on fast whether your matchine is on or not.
 

·
Premium Member
Joined
·
233 Posts
The relay was tripped. I reset it and all was well.

The top wire on the fan switch felt a little loose too. I fixed that before I reset the switch.

One way to test the fan is to undo those 2 wires from the fan switch (accessible by front right tire near back top corner of radiator) and undo the headlight wire plug right near it and run a couple jumpers to the fan switch wires (which go directly to the fan).
 

·
KFXokie
Joined
·
195 Posts
same issue in water

I ride on a river with a lot of 18 inch deep water. I had the same problem with the fan breaker. reset and still came back on. I will check the connections before I ride again. I remember someone saying keep the water proof grease on the connections to keep from having problems.
 

·
Registered
Joined
·
23 Posts
look under the drivers seat were you cdi box is the is a little braker that two wires hook up too that will be just straight femal conncetions. if your fan is not working at the time it will be realy easy to find because you can wiggle it an the fan will come on if the bike is hot. if you have warenty they will replace it but for those that just wont to fix it go buy a fuseable link thay has a 20amp fuse in it and wire it in you not have any mor problems
 

·
Registered
Joined
·
63 Posts
connections

the connections on the sender unit suck, i took mine apart and bent the connetor on the wire so it was snug when I put it back on, It was just baraly hanging on first time out!!
 
1 - 8 of 8 Posts
Top