Kawasaki Teryx Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2014 Teryx4 3635 miles 667 hours

I know I'm grasping at straws here, but I just hope this is somehow not as bad as it sounds.

1. The photo shows the 3 wires from the stator, correct? (The two separate connectors make me question it.)
2. They have continuity between them and no shorts to ground.
3. I have 2.5 and 4 volts AC with running engine, depending on the combination of leads. The voltages are steady at all engine speeds.
4. Now what?

Electrical wiring Cable Gas Fixture Auto part
 

·
Premium Member
2011 Teryx Camo, Muzzy exhaust, MSD controller, Pro Armor doors, Method beadlocks and Tensor tires
Joined
·
985 Posts
I do not have a 2nd Gen. manual in front of me, I believe there is a digital copy on this site? My 2011 manual says you should see 52 to 78 volts AC between ant two of the output leads at 4,000 rpms. A 2014 should be similar, your readings seem very low. Loss of magnetism in the rotor can also cause low output.

Mike
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks for the reply Mike.
It's the possible magnetism issue that has me scared. If I tear into it and find that the rotor needs replacing I'm afraid I'll be in over my head. I guess I've given up on the self-help and have made an appointment with the local ATV guy. I haven't used him before so that is another question mark, but I can't bring myself to go to the dealer for this either.

I'll let everyone know how I make out. Pressure washing today, deliver the machine to the witch doctor tomorrow.
 
1 - 3 of 3 Posts
Top